Screen Issues - Freezing or Flashing White
Different scenarios where you may observe the screen freezing on Palette 3 and how to troubleshoot.
Symptoms
The screen freezing, flashing or changing to solid white may occur during Palette 3's initialization or booting sequence, or during a print. Behaviors can include:
- Screen changes to a solid white color during a print (may coincide with Palette operations also stopping)
- Screen freezes near end of a print (filament is loaded in the extruder, but print is complete)
- Screen freezes and is unresponsive during print end or print cancellation
- Screen doesn't power on after pressing the power button
Note: It is normal and expected for Palette 3's screen to turn white briefly during its initialization, the power LED will be flashing green to indicate it is booting up.
Potential Causes
- The firmware installation may be incomplete
- A bootloading issue when Palette is first powered on
- Palette not receiving or able to execute end sequence, or M400
- I2C communication issue
Troubleshooting
If the unit required a power cycle after a screen freeze, observe the power LED light behavior after pressing it to power on.
- Continuously flashes red: Please try re-installing the firmware.
- Continuously flashes red and green: Allow more time to power off the unit before rebooting. Power off and unplug the unit, and wait for about 15 seconds before powering on again. If the issues persists, please re-flash the Raspberry Pi.
- Briefly flashes green before returning to solid red (screen may turn on briefly and then shutdown, screen remains off): Please re-seat the Raspberry Pi.
Other scenarios:
- Screen changes to a solid white color during a print (may coincide with Palette operations also stopping): This is currently being investigated, and is suspected to be a communication issue on Palette. If this occurs please contact support@mosaicmfg.com, with the unit's serial number, a photo of the front of the unit with the top cover off and in its error state.
- Screen turns white after beginning a print: If your screen is rotated 180 degrees, please reset it and try again. This is currently being investigated. If it is not rotated please contact support@mosaicmfg.com, with a description of the issue.
- Screen freezes near end of a print (filament is loaded in the extruder, but printer is finished building the part): It's possible that Palette 3 has more splices to create, but the printer has stopped because the part is already built. Examine how much filament is leftover at the end of the print leading to the extruder, and check the bowden tube length value entered in the Canvas profile (Printers > Edit Printer > Extruder > Bowden tube length).
- Screen continuously flashes white while powering on: Powercycle the unit by unplugging the power, wait 15 seconds before powering on again.
- Screen freezes during print end sequence or if print is cancelled: It's possible that there are commands in the end sequence that are not being received or executed. If this occurs please contact support@mosaicmfg.com, with a photo of the print showing how far it completed, and the end sequence commands, or the print file (.mcfx for connected mode printing, or .mafx and .gcode for accessory mode printing).
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