Print fails because nozzle temp set to 0

Comments

4 comments

  • Avatar
    Jonny Yeu

    Hi Donovan, thanks for this information. I’ve only seen this issue once before and was also due to the rouge ‘M104 T0 S0’ line. Removing this line helps to solve the issue.

    I’ve added your feedback and information to our Cura support article (http://mm3d.co/cura). We haven’t tested much with the more recent versions of Cura, but have found that V3.2-3.3 work best for creating Palette files with Chroma.

    0
    Comment actions Permalink
  • Avatar
    Donovan Meyers

    Thanks Jonny!

    I'm honored to contribute to your excellent documentation in even the smallest way.

    Although I am puzzled why you chose to recommend the manual Notepad++ method.

    I can only guess it's either:

    a) because my method uses an extension, but I must point out that the extension I use appears to be built-in and installed by default, so there's nothing extra to install, if that's your concern; or

    b) because you're concerned that it will remove needed M104 T0 S0 commands such as at the end, but in my testing it only removed rogue ones generated as part of the model, not ones in start gcode or end gcode.

    Leaving it as a manual step seems a sure way to either annoy the user or with an extra step in the flow, or cause failed prints when they skip the step or do it wrong.

    I humbly recommend the Cura support article be updated with the "Search and Replace" method.

    0
    Comment actions Permalink
  • Avatar
    Zaxh

    I can confirm this as an issue in Cura 4.0 as I have had several prints fail because of this without knowing about the issue. I would recommend that you put that little bit of info at the top of the support page in bold as to bring attention to it. Leaving it at the bottom makes it look like its part of the Cura 15 information.

    0
    Comment actions Permalink
  • Avatar
    Kurt Skauen

    I think Donovan Meyers's suggestion is a very good idea. It is a one-time thing that completely eliminate the problem and that does not have a manual step that you have to do for every model, and that you are bound to forget every now and then.

    And when you forget it you will often find the print to fail towards the end which is very aggravating. I to am puzzled why the support article instruct people to use the manual and error prone way rather than the automated and safe way.

    Go to the Extensions menu and click Post Processing -> Modify G-Code. Then add a Search and Replace script.

    I use the following to disable all M104 commands in the body of the gcode file. It works for both 3.6 and 4.0:

    Search: "M104 T([0-3]) S0"

    Replace: "; M104 T\1 S0 ; Disabled hotend shutdown"

    Use Regular Expressions: [X]

    This replace

    "M104 T0 S0" with "; M104 T0 S0 ; Disabled hotend shutdown"

    "M104 T1 S0" with "; M104 T1 S0 ; Disabled hotend shutdown"

    "M104 T2 S0" with "; M104 T2 S0 ; Disabled hotend shutdown"

    "M104 T3 S0" with "; M104 T3 S0 ; Disabled hotend shutdown"

    0
    Comment actions Permalink

Please sign in to leave a comment.