THIS IS UNACCEPTABLE!

Comments

18 comments

  • Avatar
    Jonny Yeu

    Hi Edward, I'm sorry that you've experienced these issues since the last update. Could you please share your recent octoprint.log files with us (support@mosaicmfg.com)? These new updates should have helped reduce these issues, so I do apologize for your recent experience.

    Also, are you running any other plugins with your CANVAS/Palette plugins?

     

  • Avatar
    Joelito Real

    No issue with my Palette on Octoprint.

  • Avatar
    Anthony Gaccione

    i'm in the same boat. even after successful prints, half the time when i attempt to start a new print the palette 2 gets stuck at the initializing screen. and yea, i have to restart everything multiple times before it will finally print. i'm printing on a CR10 using octoprint.

  • Avatar
    Jonny Yeu

    Hey Anthony, are you running any plugins besides the CANVAS/Palette plugins?

  • Avatar
    Anthony Gaccione

    Yes, i'm running some other plugins, nothing too major though. just a theme to make the octoprint page black, and one for detailed progress on the printer. i'll disable anything that i've installed (like those) and see if it helps.

  • Avatar
    Edward Boston

    I've not responded yet because I have been busy trying to figure out what the hell is going on here with very little luck.  So I went back and turned off all plugins except Canvas and Palette with no luck.  Still not working.  So I turned everything off and left it for a day.  When I came back and tried again, everything was working again, so I started turning on plugins.  After each plugin I enabled, I would restart everything and make two test prints.  Things worked fine for awhile and then after enabling one plugin, it stopped working.  So, thinking I found the problem, I disabled the plugin and try again.  Still not working.  Disabled all plugins.  Still not working.  Leave for several hours and when I come back.  Working again.  So I tried turning on *ALL* plugins at once, restarted, and everything working now.  So, the only plugins running in all tests has been the Canvas/Palette plugins.  

  • Avatar
    Jonny Yeu

    We've had another user experience similar issues and solved the issue by turning on 'Logging' in the CANVAS and Palette plugins:

    'Tired of being stuck on "Initilizing" - try this, turn on logging for the canvas and palette2 plugin...let me know if it helps, it's done wonders for me - I have a hunch and am curious if it works for others. If so, I'll put the time in to do a code change on the plugin to see if I'm right.

    To enable logging hit the wrench at the top, logging on the left, change logging levels, select items as shown one at a time, hit the +, do the second item. hit +, then hit save.'

    https://www.facebook.com/groups/mosaic.users/permalink/318033555499886/

  • Avatar
    Anthony Gaccione

     I just tried this, and it's not helping. The only plugins i have enabled aside from the Palette 2 items, are a theme for a dark octoprint view. I just tried starting a print twice, with full system reboots in between, and it's still initializing. 🤷‍♂️

  • Avatar
    Jonny Yeu

    I'm sorry to hear that, Anthony. Could you please send us your octoprint.log file (support@mosaicmfg.com)? We'll take a look to see if there are any other reasons for the constant issues you're seeing.

  • Avatar
    Edward Boston

    And here we go again.  I had finally gotten the Palette working good and then stopped using it for a week.  I went back to use it again tonight and it is hanging on the initialization screen. Nothing has changed since it was working.  No new plug-ins.  No updates to any plug-ins.  Only thing that has happened has the Palette has been turned off for a week.  As I said before - THIS IS UNACCEPTABLE!  I shouldn't have to fiddle around with this for several hours to get it to work again.  I had a project I wanted to get printed by tomorrow morning, but doesn't look like that is going to be happening now.

  • Avatar
    Edward Boston

    https://www.dropbox.com/s/xbvcxwnfoxp1u52/octoprint%20%288%29.log?dl=0 

    Here is a link to my log.  The last attempt started arourd 20:25 on Feb 5, 2019.

  • Avatar
    Jonny Yeu

    Hi Edward, we're sorry that you're running into this issue again. When you were finding success with your Palette, were you using any other plugins besides the Palette/CANVAS plugins? If so, which ones are you currently using?

    Thank you for your log files, we'll take a look at them to see if we can find the reason for this initializing issue. Does this happen with a particular file or have you seen this issue with other files as well?

  • Avatar
    Edward Boston

    It doesn't matter the file. When it starts working again, the same file that wasn't working now works. Plug-ins don't seem to be the issue either. I have had the problem with only the canvas/palette plug-ins and no problems with the plug-ins I normally use.

  • Avatar
    Jonny Yeu

    Thanks for this information, we're currently looking into the log files and will share our findings shortly.

  • Avatar
    Anthony Gaccione

    I just wanted to chime in with an update from my end. After disabling most plugins (wasn't really using anyway) except for the dark theme, i did turn on logging, as was recommended. this actually seemed to make things way worse for me. after a few frustrating days i just removed the logging items and i haven't had an issue since then. I've even powered down my printer and palette 2, and after powering both up it's been working fine. i haven't had to abort any prints yet, and that was always a pain point, so we'll see. so i'd recommend removing those logging options and see if that helps. i'm not touching any settings or other unneeded plugins now that things are working properly.

  • Avatar
    Edward Boston

    Jonny Yeu - Any update on the log file analysis?  I was able to get the Palette 2 to work on a second printer (MKS Gen 1.4 controller) with OctoPrint last night.  I make sure the OctoPrint on my other printer (Prusa i3 Mk3)had the same plug-ins and versions.  It still won't work on the Prusa. 

  • Avatar
    Jonny Yeu

    Hey Edward, sorry for the delay in my response! We didn't notice anything in the log files that sticks out, but we do plan on having an update released later this week that should help with this issue. Thanks for sharing this information about the ability to work with certain printers, I'll pass this along to our team.

  • Avatar
    Redemptioner1

    setup a Pi 3+, this resolved 90% of the “hub” issues.

    I found “detailed progress“ & “Cancel Print” plugins causes the palette the most grief with  initialising screen freeze and display errors. Turning logs on just causes more overhead on the CPU and if you are crazy enough to still be trying to use the drastically underpowered Canvas Hub then you are never going to have reliability.

Please sign in to leave a comment.