Setup Guide: CANVAS Hub

Follow
Was this article helpful?
2 out of 3 found this helpful
Have more questions? Submit a request

Comments

22 comments

  • Avatar
    Steve Clynes

    The link to the second video "Starting your first Palette 2 print : using canvas hub +..." is returning a "404 not found" error for me.

    0
    Comment actions Permalink
  • Avatar
    Thomas Leonard Gertz

    I can select the network

    but nothing happens with loe8-ch-canvas-hub.local/

    1
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hey Thomas, could you please try and enter the IP address of your CANVAS Hub into your web browser to see if you can connect?

    0
    Comment actions Permalink
  • Avatar
    John Jackson

    How do you unlink an account on the canvas hub?

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    You can do this in CANVAS by selecting the Profile logo at the top right corner, Selecting 'Manage CANVAS Hubs" and pressing the delete button next to your CANVAS Hub.

    0
    Comment actions Permalink
  • Avatar
    John Jackson

    John Jackson I un-linked the account and re-linked it again but I still can't get the canvas hub to communicate to canvas or palette 2. It will communicate to the printer.

    0
    Comment actions Permalink
  • Avatar
    John Jackson

    Palette is now connected to the hub. Canvas still shows "Not Connected".

    0
    Comment actions Permalink
  • Avatar
    Steve Clynes

    I had the EXACT same issue. Gave up, then the following night when I started everything up it was there and connected.

    I think that things are just very unstable for some reason at the moment.

    You know the drill ;-) power down everything and restart. See if that helps.

    Certainly there are some stability issues.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Also, we had an issue with on of our servers over the weekend, so I do apologize if there connection issues with users. We're working to get the server back online and it should be running again shortly.

    0
    Comment actions Permalink
  • Avatar
    John Jackson

    I can access canvas offsite through the internet but for some reason I can't access canvas hub offsite through the internet.  

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hey John, if you're trying to access the website using the serial number DNS number and not finding success, could you please find the IP address of your CANVAS Hub and enter this into your browser? You can usually find this information through your router.

    0
    Comment actions Permalink
  • Avatar
    John Jackson

    Tried the IP address and sill no luck.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hey John, could you please follow the steps in the following support article: http://mm3d.co/canvashub-connection

    0
    Comment actions Permalink
  • Avatar
    Lukas Kurka

    I've followed the guide and as written tried to update Palette 2 plugin at first. However this update fails with some messed up permissions.

    Logs are here https://pastebin.com/S1ujTfS7 and https://pastebin.com/UWK4TS6N

    How can be this fixed?

    0
    Comment actions Permalink
  • Avatar
    Kevin Mardirossian

    I too am having the above problem regarding the inability to update the Palette 2 Plugin

    0
    Comment actions Permalink
  • Avatar
    Lukas Kurka

    Hey Kevin! I didn’t have enough patience to wait over the weekend when support replies, especially when I had time and wanted to play with the machine. Have a look at https://support.mosaicmfg.com/hc/en-us/articles/360015776414-CANVAS-Hub-Factory-Reset The article aims at problems with connectivity however if you download and copy that image to SD card you will find out that it already comes with Palette 2 plugin at version 1.3 so no need to update it, only the rest. It is not probably the best solution but for me it worked:-) The wifi hotspot will be abcd-ch... instead of serial number. I have used a different sd card just for sure that I have the original untouched.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hey everyone, we'll need to update this article, but to get around the error that Lukas is experiencing, please complete the following:

    1) In the CANVAS Hub interface, please go to Settings (wrench icon) > Server > Restart OctoPrint. From here, we need to add additional information to the restart command “sudo service octoprint restart”:

    ;sudo chown -R pi:pi /home/pi/OctoPrint/venv/lib/python2.7/site-packages/

    2) Press 'Save'. Restart OctoPrint
    3) Wait ~4 minutes. Open Hub in browser again and “Update All”
    4) Wait for plugins and OctoPrint to update. Once installed, OctoPrint should restart by itself, but if not, restart OctoPrint.
    5) Wait ~4 minutes and the updates should have installed properly. 

    If you have any additional issues, please reach out to us at support@mosaicmfg.com.

    0
    Comment actions Permalink
  • Avatar
    Lukas Kurka

    Thanks for reply Jonny. As I already stated I have solved the problem with the image from your Google docs. To your solution I would maybe add point 6) put the restart command to original state - of course if there is no need to change ownership everytime you restart which I don't suppose.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Great to hear! And yes, I agree, the restart command can be returned to the original state once updated.

    0
    Comment actions Permalink
  • Avatar
    Keith Weber

    what do I do if no wifi networks show up or populate? 

     

    0
    Comment actions Permalink
  • Avatar
    Keith Weber

    I was able to get the wifi networks to populate, by leaving the hub plugged in over night. Now it populates nearly instantly when I log onto the page. But another issue, the hub does not want to connect to my wifi? 

     

     

    I put in another couple of hours trying to connect the Canvas Hub to my network, But when I choose my network and enter in the password the rebooting screen never goes away. 

    I tried logging into my network and seeing the hub but no luck. So I repeated the entering wifi credentials then waited 10 min no luck, then 30min no luck, Then an hour no luck then tried again and 2hr but no luck. 

     

     

    I get these pages when I use the attempt to reconnect or just refresh: 

    Note I could not get the XXXX-ch-canvas-hub.local/ to work even with the Http://

    I noticed that durning the reboots after about 2 to 4 mins the Hub's wifi would be activated and I could connect to it. But nothing would keep, the Network would request a password and reboot cycle would start again. 

    0
    Comment actions Permalink
  • Avatar
    Keith Weber

    Update:  I gave up after trying to use the 2.4ghz network and the advance IP scanner... But left the tab open. I played 10 or 15 games of overwatch and had dinner. 

    Then for just fun I hit refresh on the IP address and it connected... 

     

    So now I am updating and connection my account. Moral of the story plug in and wait, then wait some more. 

    0
    Comment actions Permalink

Leave a comment