Palette 2 Firmware Release Notes (Nov 6, 2019)

Follow
Was this article helpful?
4 out of 5 found this helpful
Have more questions? Submit a request

Comments

24 comments

  • Avatar
    Conrad Hosang

    Is this live yet?  The firmware update page still has a link to the older firmware (at least for Windows).

    https://s3.amazonaws.com/mosaic-resources/p2fwup/latest/Palette+2+Firmware+Updater+Setup+1.0.1.exe

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Sorry for the confusion! The updater version is different from the firmware version. This firmware update is live already, and we would suggest using the updater to receive the latest version.

    0
    Comment actions Permalink
  • Avatar
    Arnd Jurczyk

    This update has done nothing for the solution of the actual problems:

    - Buffer switch failure

    - Connection problems between Palette 2, Canvas or DIY Hub, printer

     

     

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hi Arnd, we're currently testing a solution for the Buffer switch failure and will have another update soon to help solve this. Concerning the connection issues, we've also updated the plugins recently, so please try updating these as well.

    0
    Comment actions Permalink
  • Avatar
    IronHalo

    To further Conrad's point, having the updater file named with a version number different than the firmware rev # is going to confuse people.  To cut down on the number of times you guys have to answer that question, you might consider re-naming those download files to match the firmware revision number.  

    As it stands the file has a misleading number in the name, and after you launch it there is nothing to tell you which FW version it contains.  Since just last week I have two P2 FW downloads on my computer, they are named exactly the same thing, have the same date, have the same file size, and have nothing on screen once launching them to denote what version they are.  The only way I can tell them apart is the date I downloaded them.

    Thanks, going to runs some tests on 1.2.1 now.

    0
    Comment actions Permalink
  • Avatar
    IronHalo

    Also Jonny, if you guys just released updates to the Octoprint plugins recently, they are not showing up as available updates within the Octoprint interface.  

    Here is what I'm seeing, Canvas and P2 both say 1.1.0, which are the same versions that were available at product launch I believe.  I've had them installed for at least a week, and have never updated.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hey IronHalo, thanks for the feedback, I understand how it can be confusing! The Firmware Updater is Version 1.0.1 while the actual Firmware is V 1.2.1. We'll figure out a way to simplify this for users.

    Concerning the plugins, the most recent versions are both 1.1.0, so you're up to date! If you're not sure, you can always download via URL again, but it looks like you should be fine.

    0
    Comment actions Permalink
  • Avatar
    IronHalo

    Thanks for clarifying Jonny.  Sorry, I thought I read that you guys had released new plugins within the last couple of days, so was expecting to see another plugin update. Will continue testing with these versions.

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    Jermaul West

    anyway to roll back the palette firmware update

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Not at this time. We'd recommend not rolling back to older versions of the firmware as many fixes are made to various parts of Palette on each update.

    0
    Comment actions Permalink
  • Avatar
    Donovan Meyers

    What's the best way to get notified of updates? I knew this was coming so I've been watching the page, but I can't always do that. I don't think you send out emails, even though I bought mine from you so you have my address.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hey Donovan, we usually announce firmware updates on our Facebook page (https://www.facebook.com/groups/mosaic.users/permalink/326850934618148/), but you should also receive updates if you follow the page:

     

    0
    Comment actions Permalink
  • Avatar
    Marc

    Hi, Jonny!

    I'm following this page as you recommended, but I don't receive email notifications when the article's text is updated. I do, however, receive notifications when comments are added.

    0
    Comment actions Permalink
  • Avatar
    IronHalo

    @Jonny  What Marc said above is true.  I have been following this page all along, but only get email updates when comments are added.  Simply changing the article text does not generate notifications.  Same goes for the actual FW download page.  

     

    I'm not on FB, so fortunately some people have been adding comments to these pages, or I'd have no idea there was new FW released.  Can you guys please address this?

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Thanks for clarifying! We will update this page with a comment whenever we release an update.

    0
    Comment actions Permalink
  • Avatar
    Jan Doubrava

    Bug with the last fw update.
    When calibrating for a new printer, palette asks for wrong color change.

    1. Step cleaning nozzle with transparent filament

    2. loading the filament out of palette

    3. step palette asks for color in ext.1, but that is a second color in the produced filament

    Huge problem!

    palette started to forgetting printers.
    It mostly happens when the palette is disconnected from the hub.
    We are beginning to sell palette to customers and this is a huge issue for us.
    We NEED to be able MANUALLY select a printer profile within the palette, if the palette thinks that the printer has changed.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hi Jan, could you provide some additional information about the issue that you're seeing? When you're loading the clear filament into your printer, there's no need to load the clear filament into Palette. 

    Also, are you printing the two-color keychain model (https://www.thingiverse.com/thing:3301571)?

    If possible, could you please share a video of the error that you're seeing?

    Concerning the printer profiles, Palette will create a new printer profile whenever a new slicer is being used. So if you're switching between CANVAS and Chroma, Palette will create a new printer profile. To check your profiles on Palette's screen, please go to Settings > Preferences > Printer Profiles on your Palette's screen.

    0
    Comment actions Permalink
  • Avatar
    Jan Doubrava

    1-print settup

    2-colors setup

    3-cleaning the nozzle with transparent fillament

    4-filament out of palette

    inserted to printer

    cliping the tupe

    5-loading the filament into printer, palette asks for wrong color

    as shown, first produced filament is blue (which is correct) , but palette asks for red.

    first color change:

    Is my point clear now?

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Thanks for sharing, Jan! That's definitely a bit strange. Could you please send us your MAF and GCode files (support@mosaicmfg.com)? We'll take a look.

    Have you tried to run a non-calibration print? Even though it's using the second drive first, you should still be able to complete the print if it uses Drive 1 as the second color.

    0
    Comment actions Permalink
  • Avatar
    Jermaul West

    This was posted on facebook a few days ago.
    Support said it is an error in the new firmware where it says the wrong color on loading for the calibration print.

    Should be ignored and just extruder until you see color.

    I have idea why they changed it from any color. To the drive color.
    But seems like something that should be easy and fast to fix

    0
    Comment actions Permalink
  • Avatar
    Jan Doubrava

    Jonny Yeu. I know where to find it, but that is useless, if I cannot change it.

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hi Jan, if you could please share your files with us, we can examine them to see what could be causing these issues. As Jermaul mentioned, we're aware that there is a bug with the color assignment, but we haven't seen a case where it actually pulls from drive 2 instead of drive 1. Reviewing your MAF and GCode files would help us determine what is causing this issue.

    0
    Comment actions Permalink
  • Avatar
    JJ Brown (HookUp Cellular)

    8/8/19

    Where are the help articles?

    Error (No P2 devices detected)

    Error (Opening COM7: Access denied)

    I cant take time off of work to discuss with you guys during support hours.

    Brand new, out of the box.  Does not work....................

    This is a huge disappointment!

    0
    Comment actions Permalink
  • Avatar
    Jonny Yeu

    Hi JJ, I'm sorry to hear that you're experiencing these issues. If you're having issues, please feel free to e-mail us at support@mosaicmfg.com and we'll respond as soon as possible. Concerning the issue that you're seeing, please follow the support steps here: http://mm3d.co/fwupdate-issue

    0
    Comment actions Permalink

Leave a comment