Firmware Update

Follow
Was this article helpful?
12 out of 15 found this helpful
Have more questions? Submit a request

Comments

27 comments

  • Avatar
    Joshua Chu

    Would be good to actually show what's the latest version that's available in the app.

  • Avatar
    Neal Weeks

    Palette2 should be plugged into power outlet and turned on also.

  • Avatar
    keithywhites

    can this be updated while connected through octoprint instead of moving the p2 to my computer?

  • Avatar
    Jonny Yeu

    @keithywhites not at this time, but it's something we'll discuss in the new year.

  • Avatar
    Redemptioner1

    I see there is a version 2.1.2, can you please update links and description

  • Avatar
    Pascal Cristinelli

    Je vois qu'il existe une version 2.1.2, pouvez-vous s'il vous plaît mettre à jour les liens et la description

     
     
  • Avatar
    Rodney Lorimor

    I believe you could help a lot of us if you could change the filename to reflect the version number. It would allow us to keep several versions of the software and not have to change the name ourselves. 

  • Avatar
    Jonny Yeu

    Hey Rodney, the actual download on this page is the Updater version (V1.1.1). The firmware that is uploaded from this Updater is the firmware version (V4.0.3). I apologize for any confusion.

  • Avatar
    Barry Harding

    The link for the linux updater does not work. Any help with it is greatly appreciated...

  • Avatar
    Jonny Yeu

    Sorry about that, Barry! We've just recently fixed the issue with the Linux updater, could you please try again?

     

  • Avatar
    Barry Harding

    Works as expected. Thanks for fixing it fast, saves me from trying to find a windows system :)

  • Avatar
    Jan Doubrava

    Error with the last fw update.

    When calibrating for a new printer, palette asks for wrong color change.

    1. Step cleaning nozzle with transparent filament

    2. loading the filament out of palette

    3. step palette asks for color in ext.1, but that is a second color in the produced filament

  • Avatar
    Jonny Yeu

    Hi Jan, could you provide some additional information about the issue that you're seeing? When you're loading the clear filament into your printer, there's no need to load the clear filament into Palette. 

    Also, are you printing the two-color keychain model (https://www.thingiverse.com/thing:3301571)?

    If possible, could you please share a video of the error that you're seeing?

  • Avatar
    Jan Doubrava

    Palette factory reset.

    New printer calibration.

    keychain two colors.

    In the initial change from transparent filament,

    palette asks for material in extruder 1 but the first produced filament is from ext.2

    asks for wrong color

  • Avatar
    Jonny Yeu

    Hi Jan, thanks for clarifying. Could you possibly share a video of what is occurring? We haven't seen this issue with the new update, but it may be easier to isolate the issue if we can see what is happening when Palette is asking for the wrong color.

  • Avatar
    Ramon Schweizer

    Hi Jony

    since last Firmware upgarade my Palette 2 Pro always has problem with splicing.
    The filament is breaking during print. 10 times happend so far, before the upgrade it never has been happening.

    I replaces the splicing tube without any change.

    My prusa stands still, ran out of filament. Ever end ever again.
    Palette has only spliced 25 / 250 splices, print mode is Random with 4 inputs.
    And every time the filament breaks in the Palette buffer zone.

    Sure, I can do the splice tuning, but it's strange that cames after the FW upgrade

  • Avatar
    Jonny Yeu

    Hi Ramon, I'm sorry to hear that you're receiving weak splices since the update. What are you Splice Tuning settings? If possible, could you share some pictures of your splices with these settings? We can make further recommendations once we're able to examine your splice quality. You can send this information to us at support@mosaicmfg.com.

  • Avatar
    Ramon Schweizer

    Hey Jonny

    I updated from 0,0,0 to 1,1,1 spice settings (Heat, Compress, Cool).

    It works now for me and the splices are looking same as before the update happend.

  • Avatar
    Jonny Yeu

    Hi Ramon, thanks for sharing, please let us know if you experience any further issues with your splices.

  • Avatar
    Stan Fisher

    With the known defects in 4.0.3 FW I think you guys should pull this page or at least plaster a big fat warning at the top that there are known issues being worked on when using Single Color or Multi-Spool mode that could empty your filament spool all over your work space at random.  (as I have witnessed first hand)   People who haven't updated to 4.0.3 should probably NOT do it.

  • Avatar
    Steve Chappel

    Is there access to previous firmware? I am trying to narrow down my problem, from when I was printing perfectly 1 month ago, went on a one month trip, and on return I simply updated the firmware and CANVAS plugins and I cannot get a print to work at all now. Prusa MK3 prints fine in standalone, single color, so it is calibrated just fine.

  • Avatar
    Ramon Schweizer

    Hi there

    can it be, that the new FW has some ping problems.

    I'm printing from S3D via Chroma with the Octoprint I bought together with the P2Pro.
    So far I didn't recognize some holds before going to the purge tower.
    Since I updated P2Pro with the current FW, the printer stops before moving from the part to the tower.

    How can I fix this?

    The stop is arround 1 second.

    Pings are caught and fom 99.82% to 100.18%
    Pongs are also got from 99.7% to 100%

  • Avatar
    Jonny Yeu

    Hey Ramon, I apologize for the delay in our response. Could you please share a video of when this is occurring? Also, please check to see if the temperature between your extruders is set to the same value in S3D.

  • Avatar
    Ramon Schweizer

    Hi Jonney

    We solved the problem in another topic (missing layers).

    I replaced the Mosaic Canvas Hub (PI) with a new selb bought PI3, and the problem is gone now.

    Seems, since the FW the PI had delays and kept waiting for the pings.

    It's kind of unlucky, because I extra bought the offered PI to the Palette2Pro, and now it's kind of useless.

    Anyway, it's a shame but for me fixed now.

  • Avatar
    Redemptioner1

    @ Ramon 

    Mosaic is well aware that their Canvas Hub does not work and still continue to push it and sell it. The Pi Zero inside the Hub is worth about $3 and the Developer of Octoprint (the application used on the Hub) has said numerous times that the Pi Zero (Hub) won't work with Octoprint as it is not powerful enough nor does it have enough memory.Mosaic think they know better than the developer and it seems as long as a single person can print "ok" from the Hub they won't accept it is unsuitable for the purpose they are selling it for.

    As a result, there are pauses in your print as the Pi Zero has to try and load a small amount of the Gcode into memory, read it and then prepare the host instructions all of which is more than the Zero can handle in parallel, this causes waits/delays in the host instructions going to the printer which means it stops between moves waiting for the next instruction. This is made worse by the lack of memory the Pi Zero has which means it has to do this process far too often causing even more waits/delays in printing,  

  • Avatar
    Jim Neill

    Any update to flashing the firmware via a pi connection?.  I'm comfortable with ssh to the pi and already have the octoprint firmware updater plugin installed and functional for upgrading my printer, would love to be able to do the same with my palette.  The plugin does see the palette connected.

    I'm assuming your firmware is some form of compiled arduino code or similar to a printer's firmware, couldn't we use the same plugin to flash our palette if provided a hex file? We would just need to know the parameters to use for the plugin and a hex.

     

     

     

  • Avatar
    Jonny Yeu

    Hi Jim, no updates on this as of yet, but I'll be sure to pass this information along to our team. Thanks!

Leave a comment