Skip to main content

Hub Firmware links not working

Just got 2 Refurb Hubs, opened 1 and there is no wifi, so following links, etc, I am sure I need to re-flash with new FW.

The first link to get a copy of the Firmware gives a Google version of a 404, as in the address is wrong. So unable to get new Firmware.

2nd link says I need to request permission, yet it does not allow my to do that.

Any clues please?

Update (04/06/2021)

Block Image

Is this Correct, for your link?

Update (04/07/2021)

The link now works, I downloaded that image, just in case the image I was sent by a Hub user, might have been the problem and now I can Flash the Drive ( I checked with his file again and BOTH will now Flash).

Putting the Micro back into the Hub, power on, still no Wifi, this is after several hours.

I have not tried the second Hub I got at the same time as yet but getting very close to sending them back.

Could really do with real time help if possible, I am on BST, not EST.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Hey Allan, if you are unable to flash the Hub, please send me your shipping information to alina@mosaicmfg.com. We can send over a replacement Hub for you.

by

@alina I honestly do not believe it, BOTH Hubs, exact same issues. Neither become Wifi Hot Spots when you power them on. Fought with one for hours to Flash it, failed, Failed, Failed then Success, only to Fail after verification. Opened up the second Hub this AM, just the same. Not very impressed Alina....... Sending my Shipping info via E-Mail. Thanks

by

Add a comment

1 Answer

Hey @nimiq1, thanks for bringing this to our attention and so sorry for this inconvenience. The image file for the Canvas Hub is now back up on the article. We recommend this reset if you do not see a hotspot for the Hub in your list of networks (called xxxx-ch-canvas-hub).

Was this answer helpful?

Score 0

Comments:

I am a little frustrated as this HUB, is straight from Toronto, no WiFi connection upon startup. Now I have followed the steps using Etcher and all I get is Flash Failed..... Any more idea's please.

by

So sorry about this Allan, please check our email thread as we can replace these Hubs ASAP.

by

Thank you everyone in T.O, it is all being handled now and I look forward to a much better experience with the new Hubs.... Thank You

by

Add a comment

Add your answer

Allan Bannister will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 31

Past 30 Days: 31

All Time: 31

Send our support team a message

© 2020 Mosaic Manufacturing Ltd.