Skip to main content

small isue after upgrade Palette 2 Pro to 2 Pro S

Hi there,

I just bought and install the Upgrade kit for the Palette Pro 2S model. I have followed the instructions and everything went smooth (installation). Calibrating is something else, my extruder is calibrated and works fine in slic3r. But with the Palette it seems that the pings are changing a lot (canvas and hub), especially for the first input of the Palette. for inputs two and three of the Palette 2 these seams to be much more stable. BTW: I'm printing with Prusament PETG. I properly need to tweak a little bit more.

Now the problem:

Unfortunately, I have tried to print approx. 5-6 prints and now the home-switch is not working. I have already replaced it with the spare one. But I thought these new switches were better than the original (2 pros) switches. How can I buy spare ones in the Netherlands?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Hey @mtemmink, thanks for reaching out and sorry for the trouble. If you send us your shipping information to support@mosaicmfg.com along with your order ID or receipt, we can send you a new homing switch ASAP. In terms of calibration, please make sure to run the calibration keychain (mm3d.co/firstprint) and splice tuning with your filament (mm3d.co/splice-tuning).

Was this answer helpful?

Score 0
Add a comment

Add your answer

Martin Temmink will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 6

All Time: 6

Send our support team a message

© 2020 Mosaic Manufacturing Ltd.