Skip to main content
Discussion Topic
User avatar

Print is not the same as preview


I have a serious problem with Canvas / Palette 3 Pro. If not solved I will have to return the Palette 3 Pro to the supplier as being useless. But since I am new I hope I am making an error. Please Help!!!!


I am trying to print rails for my garden train. This is what they should look like:

Block Image


So I made this drawing:

Block Image

The preview after slicing looks ok as well, for both slicers.

Block Image

However this is what I get with KISSlicer. Notice how the metal has moved, rendering the rails useles:

Block Image

And even worse is what I get with Slic3r

Block Image

Please help: What is wrong / what am I doing wrong?

Thanks in advance

Richard Boekamp

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 0
Add a comment

2 Replies

Most Helpful Answer
User avatar

Hi Richard,

I apologize that you are not having an ideal experience printing so far. I'd be happy to help with this.

This could be caused by a variety of factors, I think we will need some more information to narrow it down.

So I can best assist, I would like to take a look at your Canvas project. You can share it with me by following the instructions at Please select all boxes to share printer, style and material settings. You can then send the link to me at

Thank you for your patience and sorry for the inconvenience. I look forward to hearing from you.

Update (11/01/2023)

Hi Richard,

Sorry for the broken link, thank you for sharing that project! There are a few things jumping out at me here that I would like to adjust.

I notice you are using side transitions on this print. As the misallignment begins at a color change, I'm wondering if we are having some skipping during that movement that leads the printer to move off course when returning to print the rails. As layer shifting is much easier to track when we have a transition tower, I would recommend disabling side transitions and attempting a print with the tower enabled.

I would also recommend you enable supports, as there are overhangs under the rails that could use them.

You mentioned that you made the model in question. It may be worth running it through an .stl repair tool, just in case. Also, I was wondering what method you used for the successful version of the print at the top of your post? Were the components printed seperately and glued together in that version or did you use a different MMU?

Please let me know how it goes with these changes. If you have any questions in the meantime don't hesitate to reach out!

Was this reply helpful?

Score 1


SOLVED. It turns out that the Palette 3 Pro is NOT 100% compatibel with the Creality Sermoon D1. I changed that printer for a Creality 3D Ender 3 S1 Plus and now everything is working just fine. I could not test this earlier ince the supplied USB cable fits not in the Creality 3D Ender 3 S1 Plus and I only had loading cables and had to wait a bit on the data cable.

Thnks for your support.

By the way: the succesfull version was made without the Pallete 3 Pro, but the filament was change manually at exact timings. It works but the timing is annoying. That is exactly why I bought the Palette 3 Pro.

1 more question though. Why do I have to enter the backup filament manually again with each print? Why not just remember it until it is used for the first time?


I'm happy to hear that you were able to resolve the problem with your printer profile. Apologies for not letting you know it was not compatible, I was under the impression you were using a CR-10S based on your Canvas project.

For timing issues, your loading offset may need to be modified. If you haven't done so yet, I recommend you print our calibration keychain ( it is very helpful for determing where tweaks need to be made in regards to filament changes. Please share photos of the completed print with us at if you would like assistance.

In regards to your last question, could you clarify what you are referring to when you say backup filament?


Add a comment
User avatar

The link provided gives: err_connection_refused.

However, I think you mean this:

Was this reply helpful?

Score 0
Add a comment

Join the discussion

Author avatar Just4Fun will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 6

All Time: 33

Contact Mosaic Support Team

© 2023 Mosaic Manufacturing Ltd.