Skip to main content

Palette 3 Pro not recognizing files on USB

I just plugged in my new Palette 3 Pro and am trying to get it up and running. It didn’t do any automatic firmware updating during setup, but I checked the firmware version against what is available (it currently has 21.11.26.0 installed vs. 22.04.19.0 available online) and realized it needed an update. On the firmware screen, pushing the “Check for Updates” button gets me a “Checking for updates” notification, but it goes back to “Check for Updates” without giving me any more information or doing any updating. When I try to use the “Update via USB” option, it tells me it doesn’t see any firmware files on the USB. The firmware file is zipped and on the USB just as I downloaded it from the Mosaic website.

I tried following the recommendations in this forum post: Palette 3 won't update via USB

  • I verified that the USB was formatted FAT32.
  • I also tried uploading an MCFX file, but that is also not detected by the Palette 3 Pro when I try to start a new print.
  • I tried with two different USB drives and got the same results on both.
  • One of the USBs I tried lights up when it’s plugged in, so I know that the USB A port is physically connecting to the USB drive.
  • I tried both USB A ports with both USB drives.

Some other observations:

  1. When I try to “Link to Canvas” I get an error that says “Unable to connect to Canvas and retrieve activation code.”
  2. When I connect the Palette 3 Pro to my printer (a MK3S), the Palette says that it’s connected, so I believe the USB port is talking to the printer and therefore functioning. I obviously haven’t done any test prints though since I can’t connect to Canvas or upload prints via USB.
  3. I have connected the internet via both ethernet and Wi-Fi, both of which show as connected, but without any changes to any of the above problems.

My initial thought was that I couldn’t connect to Canvas because the firmware was too out of date, but maybe all of these problems are related. I’d appreciate any help that I can get.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I was able to get this to work by updating the firmware to 22.03.29.0 first. For some reason, this firmware version was detected on the USB but 22.04.19.0 wasn’t. The MCFX file I had uploaded on the USB only showed up once I updated the firmware.

I still can’t connect to Canvas (the “Unable to connect to Canvas and retrieve activation code” error still persists), but I’m at least up and running now with a test print. If the Canvas issue doesn’t resolve itself, I’ll just create a new forum post to keep it separate from my original issue.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Hayden Fischer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 30

All Time: 30

Contact Mosaic Support Team

© 2021 Mosaic Manufacturing Ltd.