Skip to main content

Trouble connecting my Palette 3 Pro to my internet

I have already downloaded the latest update for the Palette and when I try to connect to my WIFI, it tells me the I have the wrong password. I have already tested my password using my phone and I do have the correct one. Just need help figuring out what the issue may be. Thanks in advance

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

I have been having the same issue. I had already connected successfully many times, then suddenly the P3 Pro showed Connected, but No Internet. Subsequent boots had the same issue. Reported signal strength was "Excellent." I then tried re-entering the network password, and consistently got the error saying either the network name or password was wrong on multiple retypings and retries. I knew the password was entered correctly. At that point, I rebooted from the touchscreen, and it connected, and had internet access. I haven't dared to try disconnecting/reconnecting, so I don't know if this is reproducible.

Maybe WiFi configuration gets damaged, and does not get reinitialized properly until the password is re-entered, allowing the next boot and initialization to succeed(?)

by

BTW: I've been using FW 04.19

by

Same problem today. It seems random.

by

Add a comment

1 Answer

Hi @mcop28, we’ll be able to look into this further with logging on Palette 3. With the 04.19 firmware release, logging will be available under System settings. Since you mentioned you already have the latest update installed, can you try connecting to WiFi again, and if you still can’t connect please email the logs to support@mosaicmfg.com, or adalyn@mosaicmfg.com. Thank you!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Mark Copa will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 10

All Time: 43

Contact Mosaic Support Team

© 2022 Mosaic Manufacturing Ltd.