Skip to main content

My palette 2 is not initializing

My palette 2 s pro is stuck on “initializing palette”

what is the problem…?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

5 Answers

Hey @ehaddad, sorry for the trouble - often power cycling Palette will resolve this issue. Please let us know if this does not work for you and we can try further troubleshooting!

Update (10/07/2020)

Hey @muckychris, sorry about this - if power cycling does not solve this issue, it is likely a problem with the homing switch (the switch right below the cutter wheel). Could you take the acrylic cover off and take a photo of the switch? Could you also test the health of the switch by going to Settings —> About —> Next —> Next and seeing if the homing switch says “Pressed” when there is filament going through it, and “Not Pressed” when there is no filament present? It might be best to email this information to us at support@mosaicmfg.com with your shipping address attached, as if we do find that the switch is faulty, we will send you a new one ASAP. Thanks for your patience.

Was this answer helpful?

Score 0
Add a comment

I’m having same problem with Palette 2 pro.

Machines hangs at “initializing palette”.

Cutter wheel just spins.

Tried power cycle with no improvement.

Which direction do i look for solution?

Was this answer helpful?

Score 0

Comments:

I have this same issue. Did you ever find a fix?

by

Hey @muckychris, sorry we missed your question! The solution here would be to replace the homing switch. For other users with a similar issue, please reach out to us at support@mosaicmfg.com with your shipping information and we can send a replacement switch.

by

Add a comment

Check to see if the magnet is still on the cutting wheel. I had an issue just now where i had a broken piece of filament in the cutter. So i removed the piece and when i went to start the palette2s it wouldn’t start, just the cutter moving. Tried almost everything and nothing worked and the when i searched for cutter keeps moving i noticed there was a magnet on the wheel and low and behold sitting on my screwdriver which i used to get the broken piece of filament out with was the magnet. So i put the magnet back in with some glue and hey presto its now working again.

Was this answer helpful?

Score 0
Add a comment

Having the exact same issue. This thing is junk. From the factory it had faulty parts. Took for ever to get replacement parts, replaced them, and now it wont even get passed initializing. Their “new” parts made the problem worse and bricked my machine.

Was this answer helpful?

Score 0
Add a comment

As Alina mentioned earlier, this is likely an issue with the homing switch. Please check that the tab on the homing switch is working properly. If a replacement is needed, please send us a message at support@mosaicmfg.com

Was this answer helpful?

Score 0
Add a comment

Add your answer

Eid Haddad will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 7

All Time: 176

Contact Mosaic Support Team

© 2021 Mosaic Manufacturing Ltd.