Skip to main content
Discussion Topic

Palette 3 won't update via USB

So I’m just trying to get my Palette 3 Pro running. It automatically updated to the latest firmware on setup, BUT I was going to use it with my Prusa I3 Mk3s+. Thankfully an acquaintance informed me that I needed the Alternate firmware before I set out printing, however I cannot seem to update the firmware. I load the Alternate firmware zip contents onto the USB stick, plug it into the P3P, enter the Firmware->Update via USB, and nothing is there. The P3P isn’t seeing anything on the USB stick. I put the stick in two different computers, wiped it clean and reloaded it. I tried restarting the P3P, connecting to each USB port on it, and nothing is working. It just says there is nothing found on the USB stick every time I open up the menu.

Am I missing something? I tried shuffling the zip contents and just dumping them into the main stick directory, that didn’t do anything. The firmware update instructions make it seem like this is all I should have had to do…

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 1
Add a comment

1 Reply

Hi @mandicreally, sorry to hear you had this happen while trying to update the firmware.

If you are finding that the USB drive is also not reading Palette files for printing (MAFX for accessory mode, MCFX for connected mode), and that the USB drive was formatted with FAT32 but still not working, it’s possible that the drive is faulty.

If you have another USB drive available please try using that instead. We can also offer to ship you a new USB drive and some splice tubes for the trouble.

Was this reply helpful?

Score 0
Add a comment

Join the discussion

Alan Mandic will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 8

All Time: 49

Contact Mosaic Support Team

© 2022 Mosaic Manufacturing Ltd.