Skip to main content

Error Code 43 - USB connection lost after random time

Hi,

By now I believe I might have a faulty Palette2.

I’ve been working with it for 1.5 years but have not had many prints go through to the end. Small things work sometimes. On longer prints the chance of success seems low.

The USB connection usually gets lost after some time. The Palette shows Error Code 43 then.

What I have tried:

  • Palette connected to Octoprint on Raspberry3b+ and using Marlin
  • Palette connected to Octoprint on Raspberry3b+ and using Duet2 Wifi running Reprap
  • Palette connected to Klipper using Raspberry 4b and SKR 1.4
  • I have updated the Palette Firmware (even though it was up to date already).
  • I am using the original cables and power supplies, both for Palette and Raspberry
  • I had always thought it might be Octoprint, until I tried it with Klipper on another printer and had the same issues… So now it must be the Palette itself?
  • What could be causing these connection issues? Is there any other ideas I could try?
Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

After about 100h I can confirm that the original cable must have been the cause for the connection drops.

I replaced it with a new cable and the problem is gone. Thanks for the hint!

by

Add a comment

1 Answer

Chosen Solution

If you’re using the original cables then maybe they might have degraded and gone dry solder, grab a nice new set and don’t skimp on the money for them, also if you have any of those magnetic farrad clamp things you see on power cables throw one on, i had a lot of noise cleared up when i added one to my home printer.

Was this answer helpful?

Score 1

Comments:

I'll switch to another shorter USB cable with thicker insulation. Hope that helps.

by

Add a comment

Add your answer

Ben Bee will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 8

All Time: 108

Contact Mosaic Support Team

© 2022 Mosaic Manufacturing Ltd.