Skip to main content
Discussion Topic

Has anyone had the Palette 3 Pro freeze up?

Still trying to get my first successful print. On my 3rd try after having to adjust splice tuning for the first 2, the print seemed to be working great, so I went to bed. Next morning the extruder is 3 inches above where the model stopped getting filament, and Palette is happily going along sending gcode to the printer. No filament has moved out of the extruder for hours, however the printer still moves like it’s printing. No breaks, no clogs, just no movement in the filament.

I tried pausing, then stopping the print via the touch screen but it would not respond to anything, so I went to the computer and stopped the print from the Setup menu there. Then the Palette responded and changed the screen to the bar, finishing up all queued commands. Two hours later that bar had not moved, so I tried to power off the Palette by holding down the power button for a very long time (longer than it would normally take.) I had to pull the plug to shut it down.

Any ideas at this point would be welcome.

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 6
Add a comment

16 Replies

I have not had that exact problem but I have had it just stop printing a few times. It just seems to freeze, everything stops. You can cancel the print but then it just hangs with the “finishing up all queued commands” bar, which it does every time I cancel a print.

Was this reply helpful?

Score 0

Comments:

Ok this is pretty much exactly what happened to me on a 33 hour print. So far I have a nice looking keychain but I had to make it myself because the wifi wouldn't connect at my house and that caused the set-up to stop, and there's no way to restart the setup and rerun the keychain. Apparently factory reset used to work, but after I got the wifi working on an access point that I had to go out and buy, the Palette did upgrade the firmware and not it won't reset to defaults.

I'm not really knocking the hardware but the software needs at least a year more work on it. I wonder can we get this subject tagged by a Mosaic rep so we know they are aware that the Palette 3 Pro is hanging during print? Is anyone from Mosaic seeing this?

by

Add a comment

I have been seeing these problems as well. Print stops halfway through.. I have seen 3 other people have this problem

Was this reply helpful?

Score 0
Add a comment

I also just had a freeze for the first time. 17hrs in on a 28hr print. the palette would not advance filament and the extruder was simply out as the palette was frozen. I also noticed the interface was frozen and I had to pull power to reset it. I am on the latest firmware. P3P

Was this reply helpful?

Score 0
Add a comment
Most Helpful Answer

Yes, I had the same freezing issue and also had to unplug the palette.

Was this reply helpful?

Score 1
Add a comment

Very interesting thread.

Currently I have the issue nearly each job, and always during the loading phase, after some splices and always during a splice. The outgoing filament is cut, retracted in the input then the P3P freezes, the output drive is stuck and the buffer is reduced to the minimum until the extruder starts grinding the filament or the palette goes into an error (no filament move detected).

I’m not able to perform any job, but one.

The only way to exit that state is to cancel the print. Generally no need to restart or unplug the palette, but sometimes it goes to the “finishing up all queued commands” bar, then the only option is to unplug the palette.

Was this reply helpful?

Score 0
Add a comment

My palette 3 pro also freezes up from time to time, extruder just grinds away the filament as no new filament is fed and the palette 3 pro becomes unresponsive to any input. Only option is te hard reset by pulling the plug, restart the device, purge all filament and restart the print. I find this a very serious issue.

Was this reply helpful?

Score 0
Add a comment

I have a P3P running the latest firmware in connected mode and using canvas and it would appear that every time the system encounters a pong it freezes up my ender 6 running InsanityAutomation’s Marlin 2.0. I also have the issue when I cancel a print it gets stuck on the completing commands bar. So far the only fix I have found is to pause and unpause so that the printer executes the next part of the gcode. I have tried with the G4 P0 mode in Canvas as well as the M400 mode.

Was this reply helpful?

Score 0
Add a comment

I was 1 day into a three day print with my P3 Pro and when I tried to upload the next sliced project Canvas gave me a connection error. The device status went to offline in Canvas so I thought okay, after this print I’ll restart it. I came back in the room 2 hours later to check on it and the palette did not respond to any touch screen press and it was splicing the same filament lengths for the layer 2 hours ago when I tried to send my new print to device in Canvas.

Was this reply helpful?

Score 0
Add a comment

I am having this problem on both of my Pallete 3 Pros. I have not been using them for a few months and then started using them again recently, which leads me to believe this problem may have been introduced in the latest firmware. Previously I was running into this very same issue when trying to use Palette to do single material prints, but never multi-material prints. It is very disappointing to see the lack of communication from Mosaic team in these threads. Is there any solution?

Was this reply helpful?

Score 0

Comments:

Hi @haydenotto, Our apologies for the inconvenience this issue has caused you, and for the delay on our thread responses. We’re still transitioning as few of our members have left, meaning we have been short staffed. In spite of that, we’re making sure that we remain responsive across our various support channels. Please be advised that we have already responded to your email. We appreciate your patience.

by

One of the issues I found was that the CPU on the raspberry pi compute module has no heat sink and the cooling fan is 6-8” away. I solved a lot of my freezing issues by installing a 20x20x11mm copper heat sink.

The palette usually prints good after a factory reset, however, once it has logged so many pings and pongs (3-4 prints) it seems to suffer from memory shortages and the only way to get mine working again is to do a factory reset which purges the log files. The next firmware update should delete older logs to free up memory on the clearly inadequate module.

by

That's interesting, didn't know it had Raspberry Pi inside... but I have a bunch of the Pi heat sinks laying around and I might try putting those on it.

by

@smibble This is very good information, thank you Karl.

I have a 22h print running right now and I'm mortified it will fail because of a P3P error.

by

Add a comment

I had the same problem with freezing. My first thought was that it was supposed to be like this and I went to do other things. I came back an hour later, but nothing had changed. I was terrified and was afraid to turn it off with a button or plug it out. I went on the internet to look for information about it, and I watched an animated explainer video about how Palette works. I thought I had done something wrong. When I realized that it would not come back to normal, then I decided to plug it out. It was a stressful and unpleasant experience, I hope this mistake will be fixed.

Was this reply helpful?

Score 0
Add a comment

Has anyone had the freeze where you start a print and it goes through all its pre print rituals only to finally get to hit start printing and have the extruder freeze about six inches above the bed??

Was this reply helpful?

Score 0
Add a comment

This thread is almost a year old, has there been any progress in figuring out the problem? I just froze 40 hours into a 50 hour print :-( Everything was going great, the pings were spot on, the color changes were as good as they get, then I heard my extruder clicking and the P3 was frozen.

I sent my log files to support@mosaicmfg.com

Was this reply helpful?

Score 0

Comments:

it has been 2 months with no response- I guess I sent my log files into a black hole.

by

Add a comment

i have this issues also EVERYTIME!!!!

I didn´t finished even one job until now!!!!

Was this reply helpful?

Score 0
Add a comment

Listen guys, theyll probably take this down, but quit.. Its not a reliable process, just get a bambu labs printer.. I know it's expensive but its worth the lack of bs associated with setting it up. Good luck

Was this reply helpful?

Score 0
Add a comment

I am about with this disaster of a company. Another print failed after 10 hours because the %#*@ thing froze. My success rate is under 205 (I know, some folks here would love that rate!).They are off trying to make their element and array customers happy, while we are abandoned; they even admitted this in another thread. It has now been over 5 months without a firmware update, when there are definite known issues. As an aside, can you imagine giving these guys 10s of thousands of dollars for a commercial product? I am starting to think that Mosaic is what happens when some engineers with a cool idea try and build a business. In a way it is a shame, because the hardware is not that bad, but the slicer and firmware and company are a real mess. I have been working in tech for more than 30 years, and from the outside they look like a company that needs a good middle manager flushing.

In a private message I told them they are missing their chance. They have a community here that wants the thing to work, they want it to be a plug and play commodity 9do they can sell in in volume), so go out and find someone with a proven track record in building customer engagement programs, hire them, and do what they say. I am not holding my breath.

I love to tinker, so Bamboo might not be for me. I just build a Voron, and the support you get from this open source, non-commercial endeavor puts Mosaic to shame, so I think I might try an Enraged Rabbit Carrot Feeder.

The really sad part is I could not in good conscious sell my P3Pro without first telling the buyer to spend some time browsing this forum, which would surely send them running for the door.

Was this reply helpful?

Score 0

Comments:

sorry, success rate under 20%...

And it has been FIVE months since the last firmware update.

by

Add a comment

HI all,

I have the same problem. My palette 3 pro also freezes when doing a longtime print. Last night it froze after almost 21 hours printing.

Touchscreen was not working, on/off switch also not working.Had to pull the plug to turn it off. My Ender3 was printing in air.

I made a video of the situation and a copy of the log file from the palette.

Was this reply helpful?

Score 0
Add a comment

Join the discussion

Robert Burks will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 15

Past 30 Days: 59

All Time: 586

Contact Mosaic Support Team

© 2022 Mosaic Manufacturing Ltd.