Skip to main content

CANVAS did not send slice file 2nd time onward to my CANVAS Hub S

CANVAS did not send slice file 2nd time onward to my CANVAS Hub S.

I did ‘Re-slice’ and hit ‘Send to CANVAS Hub’ button on CANVAS but time stamp did not change on my CANVAS Hub S after 30 minutes. There was neither any log nor messages nor notifications like the FIRST transfer which was successful. I tried with the ‘Refresh file list’ button on my CANVAS Hub S and also rebooting it but both did not work at all.

I have to manually download from CANVAS and then upload to my CANVAS Hub S, then the time stamp updated almost immediately.

Update (08/17/2020)


Not sure why, it seems to be working fine now!

I tried 3 times just now and all of them popped up ‘File Received’ messages like the FIRST transfer and time stamp was updated immediately.

I shall keep an eye on this. Thx.

16 hours ago by W Tang

It only works INTERMITTENTLY!

I tried again today with fresh CANVAS login and CANVAS Hub S been rebooted.

It did popup ONCE and then STOPPED transferring / refreshing (not sure if these happened since there was no message at all).

I kept on ‘Re-slice’ and hit ‘Send to CANVAS Hub’ button on CANVAS to ensure slice file was updated on CANVAS.

This is extremely critical as I will not know exactly which slice file is used to be printed. It will be too late when the print is done but WRONG!

Appreciated if you can check this out and confirm ASAP. Thx.

57 minutes ago by W Tang

Update (08/17/2020)

It FAILED again without any popup / message / file transsfer this time with a brand new slice file. I have even rebooted the CANVAS Hub S TWICE but the new slice file was still NOT there.

How did CANVAS transfer / upload to the CANVAS Hub S? From the CANVAS directly to the the CANVAS Hub S?

OR Via the browser to the CANVAS Hub S LOCALLY with IP address?

Is there anywhere in the CANVAS Hub S to check if it is connected to the internet?

I actually cannot access the CANVAS Hub S home page using its name lsbs-ch-canvas-hub.local and have to use IP address instead. Would you know why and how to fix it?

This is extremely critical as I will not know exactly which slice file is used to be printed. It will be too late when the print is done but WRONG!

Appreciated if you can check this out and confirm ASAP. Thx.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Hey @tang8555, thanks for reaching out about this. If the file is getting sent most of the time, it is unlikely an issue with the Hub, but more likely an issue with internet connection. Sometimes OctoPrint can disconnect from the internet and if you are trying to send a file at that time, it may not go through. We would recommend to change the name of your project before pressing “Send” to keep track of which file was uploaded to the Hub page. Hope that helps for now and please let us know if this continues to be a persistent issue!

Update (09/21/2020)

Hey @tang8555, taking a look at one of your most recent OctoPrint logs, you are getting these two lines quite often:

octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: offline

octoprint.util.connectivity.connectivity_checker - INFO - Connectivity changed from online to offline

This indicates to us that the internet connection is unstable. Unfortunately, the best solution for this is to manually download the file from CANVAS and upload it on the Hub page, rather than using the “Send to CANVAS Hub” button.

Was this answer helpful?

Score 0

Comments:

Thx for your prompt answer but even the time stamp (Uploaded) did not change at all. Pls also refer to my last update above too. Thx.

by

Hey @tang8555, if you can access the Hub page either through the web address (please make sure to add a "/" after "local") or the IP address, then the Hub should be connected to the internet. Could you please share an OctoPrint log (instructions here: mm3d.co/octoprint-log) from a day that this issue occurred?

by

Hi, this issue persists and do not improve at all. I neither know when it is transferred successfully or fails. The only way is to keep on REBOOTING the CANVAS Hub S first before the transfer, then transfer messages / notifications will popup. This is very time consuming and annoying as I have to check and check and check ....... again again and again .....

Appreciated if you can look into FIXING this issue ASAP. Thx.

by

By the way, adding a "/" after "local" to access the Hub page did not work. Instead, on Windows, I have to put the web address (+ IP address mapping) into the 'hosts' file, then it works straight away. Thx.

by

@tang8555 We do apologize about this ongoing issue - we believe it has to do with OctoPrint's connection to the internet, especially because you are able to send prints after power cycling the Hub. Power cycling ensures that the Hub tries to reconnect to the Internet. Can you ensure that your Hub is close to your router?

by

Show 7 more comments

Add a comment

I don't think Mosaic Support will fix this issue since it is the workaround although cumbersome.

Another workaround is to download Slice file from CANVAS and upload to CANVAS Hub:

Hi, this issue persists and do not improve at all. I neither know when it is transferred successfully or fails. The only way is to keep on REBOOTING the CANVAS Hub S first before the transfer, then transfer messages / notifications will popup. This is very time consuming and annoying as I have to check and check and check ....... again again and again .....

Appreciated if you can look into FIXING this issue ASAP. Thx.

I am EXTREMELY disappointed on ALL the EXPENSIVE Mosaic products and Mosaic Support so far.

Unfortunately, to date I still have not succeeded in printing their Calibration Keychain yet!

They certainly do NOT perform up to the STANDARD or their CLAIMS.

There is NO PRODUCTIVE advice from Mosaic Support so far which HELPS.

There is NO IMPROVEMENT on my 3D-Print so far, in fact, it is TOTALLY HALTED.

At the moment I am still trying to answer Mosaic Support requests to print their Calibration Keychain Model BUT ALL FAILED!

Should it be that DIFFICULT to get ALL their GEARS to work together and print their Calibration Keychain Model FULLY & SUCCESSFULLY?

ALL THE GEARS except the 3DP are Mosaic PRODUCTS including the Calibration Keychain Model & SLICING SOFTWARE!

The WORST part is that the ENTIRE Print Process (Model > Colouring > Slicing > Slice File Transfer > Colour Control > Print Control) is UNCONTROLLABLE, UNPREDICTABLE, UNACCEPTABLE ......

despite of ALL COMPONENTS (except the 3D Printer) are Mosaic PRODUCTS.

I HAVE NOT STARTED TO PRINT ANYTHING OF MY OWN YET!

Was this answer helpful?

Score 0
Add a comment

Add your answer

W Tang will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 10

All Time: 101

Send our support team a message

© 2020 Mosaic Manufacturing Ltd.